Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

  • Windows and Mac OSX as a prepackaged installer called the Toolbelt.

  • Linux (Ubuntu Precise and Lucid, RedHat, CentOS) as part of the Treasure Agent (td-agent) package.

  • A Ruby 'gem' on any system.

...

Ubuntu 14.04 reached End of Life in 2019. Use the new version of Ubuntu.

Code Block
linenumberstrue
# 18.04 Bionic
$ curl -L https://toolbelt.treasuredata.com/sh/install-ubuntu-bionic-td-agent3.sh | sh
# 16.04 Xenial (64bit only)
$ curl -L https://toolbelt.treasuredata.com/sh/install-ubuntu-xenial-td-agent3.sh | sh
Legacy support for EOL versions is still available
Code Block
linenumberstrue
# 14.04 Trusty
$ curl -L https://toolbelt.treasuredata.com/sh/install-ubuntu-trusty-td-agent3.sh | sh
# 12.04 Precise
$ curl -L https://toolbelt.treasuredata.com/sh/install-ubuntu-precise-td-agent3.sh | sh
# Debian Stretch (64-bit only) $ curl -L https://toolbelt.treasuredata.com/sh/install-debian-stretch-td-agent3.sh | sh
# Debian Jessie (64-bit only)
$ curl -L https://toolbelt.treasuredata.com/sh/install-debian-jessie-td-agent3.sh | sh
# Debian Squeeze (64-bit only)
$ curl -L https://toolbelt.treasuredata.com/sh/install-debian-squeeze-td-agent2.sh | sh

...

The TD Toolbelt is distributed on Linux RedHat and CentOS as part of the td-agent package. TD Agent is our streaming log collector.

Code Block
linenumberstrue
$ curl -L https://toolbelt.treasuredata.com/sh/install-redhat-td-agent3.sh | sh

...

The TD Toolbelt is distributed on Linux as part of the td-agent package. TD Agent is our streaming log collector.

Code Block
linenumberstrue
# Amazon Linux 2$ curl -L https://toolbelt.treasuredata.com/sh/install-amazon2-td-agent3.sh | sh# Amazon Linux 1$ curl -L https://toolbelt.treasuredata.com/sh/install-amazon1-td-agent3.sh | sh

...

If you are familiar with Ruby, you can opt to install and maintain the td on the CLI as a gem. To install TD Toolbelt and its dependencies, simply run this command:

Code Block
linenumberstrue
$ gem install td

If you are using a Ruby environment manager such as rbevn or rvm, different versions of the TD Toolbelt can be confined within each project, environment or ruby version in use and you might need to install the td gem multiple times. Refer to the Upgrading, Ruby Gem section below for more information.

...

Open your terminal, and make sure you have the td command available.

Code Block
linenumberstrue
$ td --version
0.11.X

$ td
usage: td [options] COMMAND [args]
...

...

Mac OSX or Windows

Code Block
linenumberstrue
$ td --version

Redhat/CentOS

Code Block
linenumberstrue
$ rpm -q td-agent

Ubuntu

Code Block
linenumberstrue
$ dpkg - l | grep td-agent

...