Heroku Addon Notes

Table of Contents

Prerequisites

  • Basic knowledge of Ruby, Gems, and Bundler.
  • Basic knowledge of Heroku, including the Heroku toolbelt.
  • Basic knowledge of Treasure Data, including our Quickstart Guide.
  • Ruby 1.8 or higher (for local testing).

‘heroku td’, not ‘td’

Please use the heroku td command instead of the td command when on Heroku. The two commands have identical functionality.

td-agent only works with HTTP(S)

On Heroku, our data import daemon, td-agent, works only with HTTP(S) input. This limitation only exists on Heroku. You have access to all of td-agent’s features when using td-agent anywhere else (e.g., your own dedicated server).


Last modified: Jul 17 2014 03:01:43 UTC

If this article is incorrect or outdated, or omits critical information, please let us know. For all other issues, please see our support channels.